Quantcast

Jump to content

Welcome to GameOn365
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!




Photo * * * - - 1 votes

Determining Which Plugins Need Updated with New Minecraft Versions

Posted by Nick Admin, 19 June 2013 · 4869 views

This is going to be a quick and simple tutorial on how to determine which Bukkit plugins will most likely need to be updated when a new version of Minecraft is released. It's definitely important to keep all of your plugins up-to-date for various reasons, including bug fixes and security patches, but this article will help you get a list of the bare minimum you'll need to do when updating.

You probably already know that most plugins utilizing NMS (net.minecraft.server) code will need to be updated. But what is NMS code? It's any code from the vanilla Minecraft server, written by Mojang, and it can drastically change without warning in updates.  And how do I know what plugins use NMS code? That's what we're going to be figuring out here.
  • Download and run JD-GUI.
  • Open all of your plugins in JD-GUI. You should be drag and drop all of your plugins into JD-GUI from a folder on your computer -- no need to open them all individually.
  • Press Ctrl + Shift + S to open the Search dialog.
  • Type net/minecraft/server/* into the text area, and select the check boxes for Type and References.
You should soon see a list of plugins that contain references to NMS code, and will likely need to be updated.




December 2019

S M T W T F S
123456 7
891011121314
15161718192021
22232425262728
293031    

Search My Blog

Categories